首页 > Linux系统管理 > checking for embedded SAPI library support… configure: error:
2015
11-09

checking for embedded SAPI library support… configure: error:

编译php的时候报了

checking for embedded SAPI library support... configure: error: 
+--------------------------------------------------------------------+
|                        *** ATTENTION ***                           |
|                                                                    |
| You've configured multiple SAPIs to be build. You can build only   |
| one SAPI module plus CGI, CLI and FPM binaries at the same time.   |
+--------------------------------------------------------------------+
 
导致的原因是我的配置参数中同时使用了--enable-maintainer-zts --enable-embed ,因此编译的时候出错了,去掉--enable-embed参数编译成功。
有人说是--enable-fpm 与--with-apxs2=  不能共存,但是我是加载到apache的用了apxs也用了enable-fpm  也能编译过
最后编辑:
作者:saunix
大型互联网公司linux系统运维攻城狮,专门担当消防员

留下一个回复